Scheduled for June 03, 2025 at 6:45 PM – 7:45 PM
Affects
Apollo 14
Under maintenance from 6:45 PM to 7:45 PM
Completed
June 03, 2025 at 7:45 PMCompleted
June 03, 2025 at 7:45 PMMaintenance has completed successfully
Planned
June 03, 2025 at 6:45 PMPlanned
June 03, 2025 at 6:45 PMWe are planning for a scheduled maintenance during that time.
In progress
June 02, 2025 at 6:46 PMIn progress
June 02, 2025 at 6:46 PMMaintenance is now in progress.